Code
  1. Code
  2. CODE-1181

CHOOSE:ARMORTYPE not recognized CHOOSE?

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Cancelled
    • Affects Version/s: Not Released
    • Fix Version/s: None
    • Component/s: CHOOSE system
    • Labels:
      None

      Description

      Hi,

      I have this in an ability:
      MULT:YES CHOOSE:ARMORTYPE STACK:YES

      and I'm getting this error from the ability:
      SEVERE Ability (Special Ability) Armored Casting had MULT:YES but no CHOOSE

        Activity

        Tom Parker
        added a comment -

        Working as designed. We want to get away from CHOOSE:ARMORTYPE because (a) It didn't do what it said and (b) It has nasty interactions with how we now define armor proficiency.
        See: http://tech.groups.yahoo.com/group/pcgen_experimental/message/12563

        Assuming you have warnings on - you DO have warnings on for LST loading, right? - you should see this message:
        CHOOSE:ARMORTYPE has been deprecated. If you are looking for a replacement function, please contact the PCGen team for support

        If this function is required, it needs to be taken to _exp to hash out the issues.

        Show
        Tom Parker
        added a comment - Working as designed. We want to get away from CHOOSE:ARMORTYPE because (a) It didn't do what it said and (b) It has nasty interactions with how we now define armor proficiency. See: http://tech.groups.yahoo.com/group/pcgen_experimental/message/12563 Assuming you have warnings on - you DO have warnings on for LST loading, right? - you should see this message: CHOOSE:ARMORTYPE has been deprecated. If you are looking for a replacement function, please contact the PCGen team for support If this function is required, it needs to be taken to _exp to hash out the issues.

          People

          • Assignee:
            Unassigned
            Reporter:
            Andrew Maitland
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: