Code
  1. Code
  2. CODE-1841

Error Exporting to PDF when skins are not installed

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 6.00.0 RC1, 6.00.0
    • Fix Version/s: 6.01.02
    • Component/s: None
    • Labels:
    • Environment:
      WIndows 7

      Description

      Can't export to PDF in this version. Could export in 5.17.20.

      Sorry..I have no idea whether this is code or data or output sheets or other.

      Thanks!

      Here's the error log:

      13:49:52.990 INFO main pcgen.system.Main main Starting PCGen v6.00.0 RC1
      13:49:53.37 INFO main pcgen.system.LanguageBundle init Initialising language bundle with locale en_US.
      13:50:02.309 SEVERE main pcgen.core.Globals addCampaign Loaded Campaigns with matching names (Paizo - Inner Sea Primer) at different Locations: file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000RC1/data/alpha/paizo/pathfinder_player_companion/inner_sea_primer/inner_sea_primer.pcc file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000RC1/data/homebrew/inner_sea_primer/inner_sea_primer.pcc
      13:51:47.250 INFO Thread-7 pcgen.persistence.SourceFileLoader loadCampaigns Loading game Pathfinder_RPG and sources [Paizo - Pathfinder Roleplaying Game Core Rulebook, Paizo - Pathfinder Roleplaying Game Advanced Player's Guide, Paizo - Pathfinder Roleplaying Game Ultimate Magic, Paizo - Pathfinder Roleplaying Game Ultimate Combat, Pathfinder Savage Tide].
      13:51:52.321 LSTERROR Thread-7 pcgen.persistence.lst.AbilityLoader parseLine Illegal CHOOSE subtoken 'FEATS' 'Type=Noble' for Shadowshore District
      13:51:52.321 LSTERROR Thread-7 pcgen.persistence.lst.AbilityLoader parseLine CHOOSE:RACE not compatible (Source: file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000RC1/data/homebrew/Savage%20Tide/pfst_abilities.lst)
      13:51:52.321 LSTERROR Thread-7 pcgen.persistence.lst.AbilityLoader parseLine Illegal Token 'CHOOSE' 'NUMCHOICES=1|FEATS|Type=Noble' for pcgen.core.Ability Shadowshore District in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000RC1/data/homebrew/Savage%20Tide/pfst_abilities.lst
      13:51:54.895 SEVERE Thread-7 pcgen.persistence.lst.LstObjectFileLoader loadLstFile Error parsing file file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000RC1/data/homebrew/Savage%20Tide/pfst_templates.lst line 10: %LIST
      13:51:54.895 SEVERE Thread-7 pcgen.persistence.lst.LstObjectFileLoader loadLstFile Errors.LstFileLoader.Ignoring: %LIST not defined.
      13:51:58.61 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Dinosaur (Allosaurus))
      13:51:58.61 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000RC1/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst]
      13:51:58.61 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Dinosaur (Ankylosaurus))
      13:51:58.61 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000RC1/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst]
      13:51:58.61 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Dinosaur (Brachiosaurus))
      13:51:58.61 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000RC1/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst]
      13:51:58.61 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Dinosaur (Triceratops))
      13:51:58.61 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000RC1/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst]
      13:51:58.61 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Dinosaur (Tyrannosaurus))
      13:51:58.61 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000RC1/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst]
      13:51:58.77 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Elephant (Mastodon))
      13:51:58.77 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000RC1/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst]
      13:51:58.77 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Elephant)
      13:51:58.77 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000RC1/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst]
      13:51:58.77 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Herd Animal (Aurochs))
      13:51:58.77 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000RC1/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst]
      13:51:58.77 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Herd Animal (Bison))
      13:51:58.77 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000RC1/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst]
      13:51:58.77 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Hippopotamus)
      13:51:58.77 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000RC1/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst]
      13:51:58.77 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Megafauna (Arsinoitherium))
      13:51:58.77 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000RC1/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst]
      13:51:58.77 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Megafauna (Gylptodon))
      13:51:58.77 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000RC1/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst]
      13:51:58.77 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Megafauna (Megaloceros))
      13:51:58.77 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000RC1/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst]
      13:51:58.77 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Turtle (Giant Snapping))
      13:51:58.77 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000RC1/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst]
      13:51:58.77 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Elephant
      13:51:58.77 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000RC1/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst]
      13:52:06.845 INFO AWT-EventQueue-1 pcgen.system.CharacterManager openCharacter Loaded character Luke Prime - C:\Documents and Settings\Allen\My Documents\D&D\PCGen\characters\Luke Prime.pcg
      13:53:17.271 SEVERE AWT-EventQueue-1 pcgen.gui2.dialog.ExportDialog$PDFExporter done Could not export Luke Prime
      java.lang.NoClassDefFoundError: org/apache/avalon/framework/logger/Logger
      at pcgen.util.FOPHandler.<init>(Unknown Source)
      at pcgen.system.BatchExporter.exportCharacterToPDF(Unknown Source)
      at pcgen.gui2.dialog.ExportDialog$PDFExporter.doInBackground(Unknown Source)
      at javax.swing.SwingWorker$1.call(Unknown Source)
      at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
      at java.util.concurrent.FutureTask.run(Unknown Source)
      at javax.swing.SwingWorker.run(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      at java.lang.Thread.run(Unknown Source)
      Caused by: java.lang.ClassNotFoundException: org.apache.avalon.framework.logger.Logger
      at java.net.URLClassLoader$1.run(Unknown Source)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(Unknown Source)
      at java.lang.ClassLoader.loadClass(Unknown Source)
      at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
      at java.lang.ClassLoader.loadClass(Unknown Source)
      ... 10 more

        Issue Links

          Activity

          James Dempsey
          added a comment -

          When you installed PCGen which options did you choose?

          Show
          James Dempsey
          added a comment - When you installed PCGen which options did you choose?
          Allen Cohn
          added a comment -

          I'm pretty sure I installed everything except the skins. I always intend to install the PDF module because I make PDFs with regularity. But it's possible I could have screwed up the install. I can re-install this version if you want me to just to check...

          Allen

          Show
          Allen Cohn
          added a comment - I'm pretty sure I installed everything except the skins. I always intend to install the PDF module because I make PDFs with regularity. But it's possible I could have screwed up the install. I can re-install this version if you want me to just to check... Allen
          Allen Cohn
          added a comment -

          I just carefully installed 6.00.0 with the PDF generator (but without skins). It failed on making a PDF again. The error log is below.

          Thanks,
          Allen

          19:20:31.840 INFO main pcgen.system.Main main Starting PCGen v6.00.0
          19:20:32.495 INFO main pcgen.system.LanguageBundle init Initialising language bundle with locale en_US.
          19:21:17.49 SEVERE main pcgen.core.Globals addCampaign Loaded Campaigns with matching names (Paizo - Inner Sea Primer) at different Locations: file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_player_companion/inner_sea_primer/inner_sea_primer.pcc file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/homebrew/inner_sea_primer/inner_sea_primer.pcc
          19:21:27.596 INFO Thread-7 pcgen.persistence.SourceFileLoader loadCampaigns Loading game Pathfinder_RPG and sources [Paizo - Pathfinder Roleplaying Game Core Rulebook, Paizo - Pathfinder Roleplaying Game Advanced Player's Guide, Paizo - Pathfinder Roleplaying Game Ultimate Magic, Paizo - Pathfinder Roleplaying Game Ultimate Combat, Pathfinder Savage Tide].
          19:21:33.827 LSTERROR Thread-7 pcgen.persistence.lst.AbilityLoader parseLine Illegal CHOOSE subtoken 'FEATS' 'Type=Noble' for Shadowshore District
          19:21:33.843 LSTERROR Thread-7 pcgen.persistence.lst.AbilityLoader parseLine CHOOSE:RACE not compatible (Source: file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/homebrew/Savage%20Tide/pfst_abilities.lst)
          19:21:33.843 LSTERROR Thread-7 pcgen.persistence.lst.AbilityLoader parseLine Illegal Token 'CHOOSE' 'NUMCHOICES=1|FEATS|Type=Noble' for pcgen.core.Ability Shadowshore District in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/homebrew/Savage%20Tide/pfst_abilities.lst
          19:21:37.197 SEVERE Thread-7 pcgen.persistence.lst.LstObjectFileLoader loadLstFile Error parsing file file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/homebrew/Savage%20Tide/pfst_templates.lst line 10: %LIST
          19:21:37.197 SEVERE Thread-7 pcgen.persistence.lst.LstObjectFileLoader loadLstFile Errors.LstFileLoader.Ignoring: %LIST not defined.
          19:21:41.65 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Dinosaur (Allosaurus))
          19:21:41.65 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst]
          19:21:41.65 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Dinosaur (Ankylosaurus))
          19:21:41.65 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst]
          19:21:41.65 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Dinosaur (Brachiosaurus))
          19:21:41.65 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst]
          19:21:41.65 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Dinosaur (Triceratops))
          19:21:41.65 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst]
          19:21:41.65 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Dinosaur (Tyrannosaurus))
          19:21:41.65 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst]
          19:21:41.65 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Elephant (Mastodon))
          19:21:41.65 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst]
          19:21:41.65 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Elephant)
          19:21:41.65 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst]
          19:21:41.65 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Herd Animal (Aurochs))
          19:21:41.65 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst]
          19:21:41.65 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Herd Animal (Bison))
          19:21:41.65 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst]
          19:21:41.65 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Hippopotamus)
          19:21:41.65 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst]
          19:21:41.65 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Megafauna (Arsinoitherium))
          19:21:41.65 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst]
          19:21:41.65 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Megafauna (Gylptodon))
          19:21:41.65 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst]
          19:21:41.81 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Megafauna (Megaloceros))
          19:21:41.81 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst]
          19:21:41.81 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Turtle (Giant Snapping))
          19:21:41.81 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst]
          19:21:41.81 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Elephant
          19:21:41.81 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst]
          19:21:50.52 INFO AWT-EventQueue-1 pcgen.system.CharacterManager openCharacter Loaded character Luke Prime - C:\Documents and Settings\Allen\My Documents\D&D\PCGen\characters\Luke Prime.pcg
          19:29:49.306 SEVERE AWT-EventQueue-1 pcgen.gui2.dialog.ExportDialog$PDFExporter done Could not export Luke Prime
          java.lang.NoClassDefFoundError: org/apache/avalon/framework/logger/Logger
          at pcgen.util.FOPHandler.<init>(Unknown Source)
          at pcgen.system.BatchExporter.exportCharacterToPDF(Unknown Source)
          at pcgen.gui2.dialog.ExportDialog$PDFExporter.doInBackground(Unknown Source)
          at javax.swing.SwingWorker$1.call(Unknown Source)
          at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
          at java.util.concurrent.FutureTask.run(Unknown Source)
          at javax.swing.SwingWorker.run(Unknown Source)
          at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
          at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
          at java.lang.Thread.run(Unknown Source)
          Caused by: java.lang.ClassNotFoundException: org.apache.avalon.framework.logger.Logger
          at java.net.URLClassLoader$1.run(Unknown Source)
          at java.security.AccessController.doPrivileged(Native Method)
          at java.net.URLClassLoader.findClass(Unknown Source)
          at java.lang.ClassLoader.loadClass(Unknown Source)
          at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
          at java.lang.ClassLoader.loadClass(Unknown Source)
          ... 10 more

          Show
          Allen Cohn
          added a comment - I just carefully installed 6.00.0 with the PDF generator (but without skins). It failed on making a PDF again. The error log is below. Thanks, Allen 19:20:31.840 INFO main pcgen.system.Main main Starting PCGen v6.00.0 19:20:32.495 INFO main pcgen.system.LanguageBundle init Initialising language bundle with locale en_US. 19:21:17.49 SEVERE main pcgen.core.Globals addCampaign Loaded Campaigns with matching names (Paizo - Inner Sea Primer) at different Locations: file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_player_companion/inner_sea_primer/inner_sea_primer.pcc file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/homebrew/inner_sea_primer/inner_sea_primer.pcc 19:21:27.596 INFO Thread-7 pcgen.persistence.SourceFileLoader loadCampaigns Loading game Pathfinder_RPG and sources [Paizo - Pathfinder Roleplaying Game Core Rulebook, Paizo - Pathfinder Roleplaying Game Advanced Player's Guide, Paizo - Pathfinder Roleplaying Game Ultimate Magic, Paizo - Pathfinder Roleplaying Game Ultimate Combat, Pathfinder Savage Tide] . 19:21:33.827 LSTERROR Thread-7 pcgen.persistence.lst.AbilityLoader parseLine Illegal CHOOSE subtoken 'FEATS' 'Type=Noble' for Shadowshore District 19:21:33.843 LSTERROR Thread-7 pcgen.persistence.lst.AbilityLoader parseLine CHOOSE:RACE not compatible (Source: file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/homebrew/Savage%20Tide/pfst_abilities.lst ) 19:21:33.843 LSTERROR Thread-7 pcgen.persistence.lst.AbilityLoader parseLine Illegal Token 'CHOOSE' 'NUMCHOICES=1|FEATS|Type=Noble' for pcgen.core.Ability Shadowshore District in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/homebrew/Savage%20Tide/pfst_abilities.lst 19:21:37.197 SEVERE Thread-7 pcgen.persistence.lst.LstObjectFileLoader loadLstFile Error parsing file file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/homebrew/Savage%20Tide/pfst_templates.lst line 10: %LIST 19:21:37.197 SEVERE Thread-7 pcgen.persistence.lst.LstObjectFileLoader loadLstFile Errors.LstFileLoader.Ignoring: %LIST not defined. 19:21:41.65 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Dinosaur (Allosaurus)) 19:21:41.65 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst] 19:21:41.65 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Dinosaur (Ankylosaurus)) 19:21:41.65 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst] 19:21:41.65 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Dinosaur (Brachiosaurus)) 19:21:41.65 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst] 19:21:41.65 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Dinosaur (Triceratops)) 19:21:41.65 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst] 19:21:41.65 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Dinosaur (Tyrannosaurus)) 19:21:41.65 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst] 19:21:41.65 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Elephant (Mastodon)) 19:21:41.65 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst] 19:21:41.65 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Elephant) 19:21:41.65 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst] 19:21:41.65 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Herd Animal (Aurochs)) 19:21:41.65 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst] 19:21:41.65 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Herd Animal (Bison)) 19:21:41.65 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst] 19:21:41.65 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Hippopotamus) 19:21:41.65 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst] 19:21:41.65 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Megafauna (Arsinoitherium)) 19:21:41.65 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst] 19:21:41.65 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Megafauna (Gylptodon)) 19:21:41.65 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst] 19:21:41.81 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Megafauna (Megaloceros)) 19:21:41.81 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst] 19:21:41.81 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Companion (Turtle (Giant Snapping)) 19:21:41.81 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst] 19:21:41.81 SEVERE Thread-7 pcgen.cdom.reference.CDOMFactory resolve Unconstructed Reference: Race Elephant 19:21:41.81 SEVERE Thread-7 pcgen.rules.context.TrackingReferenceContext unconstructedReferenceFound Was used in file:/C:/Users/Allen/AppData/Local/PCGen/PCGen6000/data/alpha/paizo/pathfinder_rpg/ultimate_combat/pfuc_abilities_archetypes.lst in tokens: [plugin.lsttokens.CompanionListLst] 19:21:50.52 INFO AWT-EventQueue-1 pcgen.system.CharacterManager openCharacter Loaded character Luke Prime - C:\Documents and Settings\Allen\My Documents\D&D\PCGen\characters\Luke Prime.pcg 19:29:49.306 SEVERE AWT-EventQueue-1 pcgen.gui2.dialog.ExportDialog$PDFExporter done Could not export Luke Prime java.lang.NoClassDefFoundError: org/apache/avalon/framework/logger/Logger at pcgen.util.FOPHandler.<init>(Unknown Source) at pcgen.system.BatchExporter.exportCharacterToPDF(Unknown Source) at pcgen.gui2.dialog.ExportDialog$PDFExporter.doInBackground(Unknown Source) at javax.swing.SwingWorker$1.call(Unknown Source) at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source) at java.util.concurrent.FutureTask.run(Unknown Source) at javax.swing.SwingWorker.run(Unknown Source) at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source) at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) at java.lang.Thread.run(Unknown Source) Caused by: java.lang.ClassNotFoundException: org.apache.avalon.framework.logger.Logger at java.net.URLClassLoader$1.run(Unknown Source) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(Unknown Source) at java.lang.ClassLoader.loadClass(Unknown Source) at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source) at java.lang.ClassLoader.loadClass(Unknown Source) ... 10 more
          Allen Cohn
          added a comment -

          I just reinstalled 6.00.0, this time including the skins. This time it makes PDFs no problem. I suppose I should now reinstall it one more time without the skins to confirm that the problem comes back...

          Show
          Allen Cohn
          added a comment - I just reinstalled 6.00.0, this time including the skins. This time it makes PDFs no problem. I suppose I should now reinstall it one more time without the skins to confirm that the problem comes back...
          James Dempsey
          added a comment -

          No need to reinstall, I can trace this one from here - thanks for the report!

          Show
          James Dempsey
          added a comment - No need to reinstall, I can trace this one from here - thanks for the report!
          James Dempsey
          added a comment -

          Resolved in linked issue

          Show
          James Dempsey
          added a comment - Resolved in linked issue

            People

            • Assignee:
              James Dempsey
              Reporter:
              Allen Cohn
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: