Code
  1. Code
  2. CODE-2086

Bardic Abilities showing 0 in output when DEFINE and BONUS:VAR are set correctly in the granted ability

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 6.00.0, 6.01.01
    • Fix Version/s: 6.00.1 RC1, 6.01.02
    • Component/s: None
    • Labels:
      None

      Description

      I've confirmed this behavior in latest trunk build. DEFINE and BONUS:VAR match, all are in place. Our Code has broken somewhere.

      USER REPORT:
      I just created a 4th level bard 1st level rogue in PC Gen 6.00.0 and all of my bardic music abilities are coming up as 0. I'm running it on an iMac Snow Leopard w/ the correct java installed if that matters... Is this a bug that needs to be reported or am I doing something wrong? I'm using 3.5 gamemode...

        Activity

        James Dempsey
        added a comment -

        It looks like chained variables are having problems when being exported. This is likely related to CODE-1893 and seems to be related to the cloning of the character that occurs prior to export.

        Show
        James Dempsey
        added a comment - It looks like chained variables are having problems when being exported. This is likely related to CODE-1893 and seems to be related to the cloning of the character that occurs prior to export.
        James Dempsey
        added a comment -

        Order of operations issue when preparing the character for output.

        Show
        James Dempsey
        added a comment - Order of operations issue when preparing the character for output.
        Kevin W Patterson
        added a comment -

        This problem appears to persist in 6.0.1.04. I can create a Bard, export to PDF, and and see 0 for all ability bonuses and duration. Should I open a new bug report on this?

        Show
        Kevin W Patterson
        added a comment - This problem appears to persist in 6.0.1.04. I can create a Bard, export to PDF, and and see 0 for all ability bonuses and duration. Should I open a new bug report on this?

          People

          • Assignee:
            James Dempsey
            Reporter:
            Andrew Maitland
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: