Code
  1. Code
  2. CODE-376

Batch processing of PCs failing

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 5.16.3
    • Fix Version/s: 5.16.4, 5.17.4 (Alpha) , 5.17 Cycle
    • Component/s: None
    • Labels:
      None

      Description

      > I had the opportunity to switch to a new Laptop. I just copied over all the
      > PCGen data and character files I had, and hoped to see a big increase in
      > responsiveness. Which I do – when using PCGen interactively.
      >
      > I am using openSUSE 11.3, with SUN java 1.6.0_22, and I tried PCGen
      > 5.16.3, 5.16.4RC1, 5.16.4RC2. In all cases, java is started, but then
      > nothing seems to be happening.
      >
      > Where can I find any kind of logfile/console output in case any is written?
      > Has there recently been a change in how batch processing should be done?
      > Do I need anything beside the PCGen full download to make it work?
      >

      1. DEBUG
        6 kB
        Susan Dittmar

        Activity

        Hide
        Susan Dittmar
        added a comment -

        Here's the console output after pressing Ctrl-\ (after java was down to less than 1% CPU time). Hope it helps.

        Show
        Susan Dittmar
        added a comment - Here's the console output after pressing Ctrl-\ (after java was down to less than 1% CPU time). Hope it helps.
        Hide
        James Dempsey
        added a comment -

        The debug shows that java is waiting and not processing anything. I'll look into it further.

        Show
        James Dempsey
        added a comment - The debug shows that java is waiting and not processing anything. I'll look into it further.
        Hide
        James Dempsey
        added a comment -

        Reproduced on windows

        Show
        James Dempsey
        added a comment - Reproduced on windows
        Hide
        James Dempsey
        added a comment -

        I have fixed an issue with the sources not loading, but when this error occurs the program would have exited with an error in the console (std out or std err).

        If the program is hanging it is likely that your -Dpcgen.inputfile entry is not being picked up correctly, as was mine when I reproduced the issue (my mistake as it happened). I would try replacing the pwd command with a static path just in case and also confirm that you are invoking Sun's JDK.

        Show
        James Dempsey
        added a comment - I have fixed an issue with the sources not loading, but when this error occurs the program would have exited with an error in the console (std out or std err). If the program is hanging it is likely that your -Dpcgen.inputfile entry is not being picked up correctly, as was mine when I reproduced the issue (my mistake as it happened). I would try replacing the pwd command with a static path just in case and also confirm that you are invoking Sun's JDK.
        Hide
        James Dempsey
        added a comment -

        Fixed load sources issue. However it is likely that the reported error is in Susan's batch script or environment.

        Show
        James Dempsey
        added a comment - Fixed load sources issue. However it is likely that the reported error is in Susan's batch script or environment.
        Hide
        James Dempsey
        added a comment -

        From: eslaf1234
        To: pcgen@yahoogroups.com

        Susan

        Try ticking the "Autoload Sources with PC" in Preferences/Pcgen/Sources,
        they changed the default between 5.16.2 and 5.16.3 (at svn rev 12569)
        for some reason. Or you could set pcgen.options.loadCampaignsWithPC to
        true in options.ini.

        That solves the failure to load the sources problem for me but I still
        suffer for the java not exiting. I reported the problem of long hang
        times with command line exports back in august 2009 with a simple fix of
        exiting after export, can't access the old sourceforge tracker
        (https://sourceforge.net/tracker/?func=detail&atid=384719&aid=2836931&group_id=25576)
        anymore and can't see it in JIRA anywhere. It was changed to "To be Fixed
        for 6.0" by karianna so was not going to be fixed soon. Hopefully its
        just my setup that causes java to hang and the above will fix your problem.

        Mark

        Implemented patch from SF tracker. This should solve the process hanging problem.

        Show
        James Dempsey
        added a comment - From: eslaf1234 To: pcgen@yahoogroups.com Susan Try ticking the "Autoload Sources with PC" in Preferences/Pcgen/Sources, they changed the default between 5.16.2 and 5.16.3 (at svn rev 12569) for some reason. Or you could set pcgen.options.loadCampaignsWithPC to true in options.ini. That solves the failure to load the sources problem for me but I still suffer for the java not exiting. I reported the problem of long hang times with command line exports back in august 2009 with a simple fix of exiting after export, can't access the old sourceforge tracker ( https://sourceforge.net/tracker/?func=detail&atid=384719&aid=2836931&group_id=25576 ) anymore and can't see it in JIRA anywhere. It was changed to "To be Fixed for 6.0" by karianna so was not going to be fixed soon. Hopefully its just my setup that causes java to hang and the above will fix your problem. Mark Implemented patch from SF tracker. This should solve the process hanging problem.

          People

          • Assignee:
            James Dempsey
            Reporter:
            Tom Parker
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: