Data
  1. Data
  2. DATA-1077

Fighter Weapon Training and the Marksman's Favored Weapon for thrown weapons does not bonus the Blowgun, Sling, or Halfling Sling Staff

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 6.01.01, 6.00.1
    • Fix Version/s: 6.01.10
    • Component/s: Pathfinder Game System
    • Labels:
      None

      Description

      I just went through the material and narrowed down the problem. The Marksman's Favored Weapon (Thrown) ability explicitly includes the Blowgun, Sling, and Halfling Sling Staff, none of which carries the "Thrown" type. This means we need to either add the Thrown type to these three weapons or add them explicitly to the Favored Weapon (Thrown) ability.

      UPDATE: This problem also effects the Firghter Weapon Training (Thrown) class ability.

        Activity

        Eric C. Smith
        added a comment -

        Going through the logic, this bug may be even bigger still . . .

        If a Fighter, or Marksman, takes the relevant class ability for Thrown Weapons, any weapon that is included in multiple groups, say the Short Spear, will be bonused no matter how it is used as long as the character has any one of the short spears relevant abilities.

        As an example, assume a Halfling Marksman with Favored Weapon (Spear). If that halfling uses a Short Spear as a melee weapon the To-Hit gets bonused. He he then decides to throw the short spear, his tohit on the OS gets the same bonus.

        Likewise, if the same halfling Marksman instead has the Favored Weapon (Thrown) and uses a Short Spear as a melee weapon, he gets the same bonus for the ToHit for the spear on the OS . . .

        Is this the intended behavior from the Rules Mechanic? (Not from the PCGen perspective . . . )

        Show
        Eric C. Smith
        added a comment - Going through the logic, this bug may be even bigger still . . . If a Fighter, or Marksman, takes the relevant class ability for Thrown Weapons, any weapon that is included in multiple groups, say the Short Spear, will be bonused no matter how it is used as long as the character has any one of the short spears relevant abilities. As an example, assume a Halfling Marksman with Favored Weapon (Spear). If that halfling uses a Short Spear as a melee weapon the To-Hit gets bonused. He he then decides to throw the short spear, his tohit on the OS gets the same bonus. Likewise, if the same halfling Marksman instead has the Favored Weapon (Thrown) and uses a Short Spear as a melee weapon, he gets the same bonus for the ToHit for the spear on the OS . . . Is this the intended behavior from the Rules Mechanic? (Not from the PCGen perspective . . . )
        Douglas Limmer
        added a comment -

        The fighter ability just says that the fighter gains the bonus when using the weapon; it doesn't make any mention of how the weapon is used.

        The marksman ability does specifically say that the marksman gains the bonus only for ranged attacks. Right now, it's coded to always give the bonus, regardless of how the weapon is used, which is wrong. I'm not sure if there's some combo of existing tags that will limit the bonus to just ranged attacks, or if a code/new tag fix is needed.

        Show
        Douglas Limmer
        added a comment - The fighter ability just says that the fighter gains the bonus when using the weapon; it doesn't make any mention of how the weapon is used. The marksman ability does specifically say that the marksman gains the bonus only for ranged attacks. Right now, it's coded to always give the bonus, regardless of how the weapon is used, which is wrong. I'm not sure if there's some combo of existing tags that will limit the bonus to just ranged attacks, or if a code/new tag fix is needed.
        Andrew Maitland
        added a comment -

        How's this coming along Eric?

        Show
        Andrew Maitland
        added a comment - How's this coming along Eric?
        Andrew Maitland
        added a comment -

        Waiting on Eric's thoughts and responses

        Show
        Andrew Maitland
        added a comment - Waiting on Eric's thoughts and responses
        Andrew Maitland
        added a comment -

        At revision: 22189

        Show
        Andrew Maitland
        added a comment - At revision: 22189

          People

          • Assignee:
            Andrew Maitland
            Reporter:
            Eric C. Smith
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: