Data
  1. Data
  2. DATA-907

Druid Domain does not allow the druid domains to be selected

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 6.01.01
    • Fix Version/s: 6.00.1 RC1, 6.01.02
    • Component/s: Pathfinder
    • Labels:
      None

      Description

      Create a Halfling Druid w/15 in all stats.
      Select Nature Bond - Druid Domain

      Without selecting a deity the appropriate domains, per PFCR, are visible but all are red and cannot be selected.

      Select "None" for deity and all cleric domains, except for those restricted by alignment, are now visible, selectable, and grant the domain abilities to the druid.

      Selecting any other deity makes that deities domains available.

        Activity

        Andrew Maitland
        added a comment -

        Not a Bug. Please realize that the NONE Deity option grants EVERY Domain by default. It is working as designed. Unless you are proposing the complete removal of deity 'None'.

        Show
        Andrew Maitland
        added a comment - Not a Bug. Please realize that the NONE Deity option grants EVERY Domain by default. It is working as designed. Unless you are proposing the complete removal of deity 'None'.
        Andrew Maitland
        added a comment -

        Same with other deities, that is the problem with using DOMAINs in the same context as a cleric. This is asking to defeat a system already in place. This is not a Data Issue. What you are asking for is a complete rewrite of the system which becomes a Code Issue.

        Or a complete rewrite of every deity in the system.

        Show
        Andrew Maitland
        added a comment - Same with other deities, that is the problem with using DOMAINs in the same context as a cleric. This is asking to defeat a system already in place. This is not a Data Issue. What you are asking for is a complete rewrite of the system which becomes a Code Issue. Or a complete rewrite of every deity in the system.
        Eric C. Smith
        added a comment -

        i disagree with you Drew. Druids should NEVER get a domain that is not one allowed explicitly by the druid rules. Clerics are a different situation. The Druid Domain ability should NOT be coded the way the Cleric domains are. Its broke.

        The same is true with all domains. The Druid doesn't get them just because they can select a domain. Thay have a restricted pool of domains to choose from.

        And yes, it everything needs to be recoded to fix this then yes, it should be done, because the Druid Domain was completely recoded to fix a problem that, in my mind created a bigger one.

        Show
        Eric C. Smith
        added a comment - i disagree with you Drew. Druids should NEVER get a domain that is not one allowed explicitly by the druid rules. Clerics are a different situation. The Druid Domain ability should NOT be coded the way the Cleric domains are. Its broke. The same is true with all domains. The Druid doesn't get them just because they can select a domain. Thay have a restricted pool of domains to choose from. And yes, it everything needs to be recoded to fix this then yes, it should be done, because the Druid Domain was completely recoded to fix a problem that, in my mind created a bigger one.
        Eric C. Smith
        added a comment - - edited

        I coded the Druid Domain in the PFCR and it worked beautifully except at 1st level. After that it settled right in and just worked. Then would have been the time to make the code fix rather than break everything else related to the Druid Domain. Especially as I don't remember any discussion about this "fix" and as the original coder for the Druid Domain, I should would have has some input.

        Show
        Eric C. Smith
        added a comment - - edited I coded the Druid Domain in the PFCR and it worked beautifully except at 1st level. After that it settled right in and just worked. Then would have been the time to make the code fix rather than break everything else related to the Druid Domain. Especially as I don't remember any discussion about this "fix" and as the original coder for the Druid Domain, I should would have has some input.
        Eric C. Smith
        added a comment -

        Oh, by the way, the original coding for Druid Domains didn't involve the deities at all, so if the current code requires a rewrite of the deities, then its just one more example of how it was coded incorrectly. The Druids domain selections is not effected by any deity selection.

        Show
        Eric C. Smith
        added a comment - Oh, by the way, the original coding for Druid Domains didn't involve the deities at all, so if the current code requires a rewrite of the deities, then its just one more example of how it was coded incorrectly. The Druids domain selections is not effected by any deity selection.
        Andrew Maitland
        added a comment -

        The only code change was to fix internal issues and make it easier to make the druid domains work (Work at 1st level) and the Premults were cleaned up as per a JAVA CODER request. Nothing was changed otherwise. There may be other solutions, but presently the accusation it was working before doesn't jive with the docs and the code. When I'm not busy working, I'll take a look and muddle some solutions, but the domains were broken before, they work now, and they are piggybacking on the cleric domain system, which means we have to work around that system somehow.

        Show
        Andrew Maitland
        added a comment - The only code change was to fix internal issues and make it easier to make the druid domains work (Work at 1st level) and the Premults were cleaned up as per a JAVA CODER request. Nothing was changed otherwise. There may be other solutions, but presently the accusation it was working before doesn't jive with the docs and the code. When I'm not busy working, I'll take a look and muddle some solutions, but the domains were broken before, they work now, and they are piggybacking on the cleric domain system, which means we have to work around that system somehow.
        Andrew Maitland
        added a comment -

        Completed: At revision: 19382

        • Addresses the actual issue of not being able to select Druid Domains.
        • Doesn't touch on the extra domains Deities will allow.
        Show
        Andrew Maitland
        added a comment - Completed: At revision: 19382 Addresses the actual issue of not being able to select Druid Domains. Doesn't touch on the extra domains Deities will allow.

          People

          • Assignee:
            Andrew Maitland
            Reporter:
            Eric C. Smith
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: