Details

    • Type: Help Request Help Request
    • Status: Closed Closed (View Workflow)
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Windows Vista

      Description

      Loading standard Pathfinder for Players works just fine, but when I try to Add a source set with the Advanced Players' Guide, I get the error message:

      SEVERE Exception loading files.
      java.lang.NullPointerException
      at pcgen.persistence.lst.LstSystemLoader$3.compare(Unknown Source)
      at pcgen.persistence.lst.LstSystemLoader$3.compare(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.sort(Unknown Source)
      at java.util.Collections.sort(Unknown Source)
      at pcgen.persistence.lst.LstSystemLoader.sortCampaignsByRank(Unknown Source)
      at pcgen.persistence.lst.LstSystemLoader.loadCampaigns(Unknown Source)
      at pcgen.persistence.lst.LstSystemLoader.loadCampaigns(Unknown Source)
      at pcgen.persistence.PersistenceManager.loadCampaigns(Unknown Source)
      at pcgen.gui.sources.SourceSelectionUtils.doCampaignLoad(Unknown Source)
      at pcgen.gui.sources.SourceSelectionUtils.access$000(Unknown Source)
      at pcgen.gui.sources.SourceSelectionUtils$1.construct(Unknown Source)
      at pcgen.util.SwingWorker$2.run(Unknown Source)
      at java.lang.Thread.run(Unknown Source)

      All Done

        Activity

        Andrew Maitland
        added a comment -

        NPE's are your field James. Is this something we've already fixed in the Trunk?

        Show
        Andrew Maitland
        added a comment - NPE's are your field James. Is this something we've already fixed in the Trunk?
        James Dempsey
        added a comment -

        Could you try this procedure please? Click on "Use Advanced Screen", click "Unload All", then add or remove the sources you want. If you had the players source loaded it will show the core rules and the web traits. You'll need to remove the web traits to use the APG. Now click Load. Does that work for you?

        You may also want to create your own custom set to appear on the basic screen. From the basic screen click Add, select your game mode and then add or remove sources as required. Enter a campaign name at the bottom and click OK. You'll then have a new option in the basic screen of your campaign name.

        Show
        James Dempsey
        added a comment - Could you try this procedure please? Click on "Use Advanced Screen", click "Unload All", then add or remove the sources you want. If you had the players source loaded it will show the core rules and the web traits. You'll need to remove the web traits to use the APG. Now click Load. Does that work for you? You may also want to create your own custom set to appear on the basic screen. From the basic screen click Add, select your game mode and then add or remove sources as required. Enter a campaign name at the bottom and click OK. You'll then have a new option in the basic screen of your campaign name.
        Katharine Sedivy-Haley
        added a comment -

        The basic screen isn't working. (That's what I tried earlier.) But the Advanced screen is working fine, so I can use that. It looks like it remembers my last load, too, so it's no less convenient than saving a set. Thanks!

        Show
        Katharine Sedivy-Haley
        added a comment - The basic screen isn't working. (That's what I tried earlier.) But the Advanced screen is working fine, so I can use that. It looks like it remembers my last load, too, so it's no less convenient than saving a set. Thanks!
        Andrew Maitland
        added a comment -

        Yeah, the Advanced Screen Remembers your last loaded set for each gamemode. Very handy in my humble opinion.

        Show
        Andrew Maitland
        added a comment - Yeah, the Advanced Screen Remembers your last loaded set for each gamemode. Very handy in my humble opinion.
        James Dempsey
        added a comment -

        Katharine could you post a screen shot or two of what is happening for the basic screen please? This process should work and I'd like to track down what is going wrong.

        Show
        James Dempsey
        added a comment - Katharine could you post a screen shot or two of what is happening for the basic screen please? This process should work and I'd like to track down what is going wrong.
        James Dempsey
        added a comment -

        Closed pending further information.

        Show
        James Dempsey
        added a comment - Closed pending further information.

          People

          • Assignee:
            James Dempsey
            Reporter:
            Katharine Sedivy-Haley
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: